VLANs on 2950 Switch
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname myname
enable secret mypass
ip subnet-zero
ip domain-name mydomain.co.uk
ip name-server xyz.xyz.xyz.xyz
ip name-server xyz.xyz.xyz.xyz
spanning-tree extend system-id
interface FastEthernet0/1
description WAN
switchport mode trunk
no ip address
duplex full
speed 100
spanning-tree portfast
interface FastEthernet0/2
description vlan2
switchport access vlan 2
switchport mode access
no ip address
interface FastEthernet0/3
description vlan3
switchport access vlan 3
switchport mode access
no ip address
interface FastEthernet0/4
description vlan4
switchport access vlan 4
switchport mode access
no ip address
interface FastEthernet0/5
description vlan5
switchport access vlan 5
switchport mode access
no ip address
interface FastEthernet0/6
description vlan6
switchport access vlan 6
switchport mode access
no ip address
interface FastEthernet0/7
description vlan7
switchport access vlan 7
switchport mode access
no ip address
interface FastEthernet0/8
description vlan8
switchport access vlan 8
switchport mode access
no ip address
interface FastEthernet0/9
description vlan9
switchport access vlan 9
switchport mode access
no ip address
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
no ip address
interface FastEthernet0/11
switchport access vlan 11
switchport mode access
no ip address
interface FastEthernet0/12
switchport access vlan 13
switchport mode access
no ip address
interface FastEthernet0/13
switchport access vlan 13
switchport mode access
no ip address
interface FastEthernet0/14
switchport access vlan 14
switchport mode access
no ip address
interface FastEthernet0/15
switchport access vlan 15
switchport mode access
no ip address
interface FastEthernet0/16
switchport access vlan 16
switchport mode access
no ip address
interface FastEthernet0/17
switchport access vlan 17
switchport mode access
no ip address
interface FastEthernet0/18
switchport access vlan 18
switchport mode access
no ip address
interface FastEthernet0/19
switchport access vlan 19
switchport mode access
no ip address
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
no ip address
interface FastEthernet0/21
switchport access vlan 21
switchport mode access
no ip address
interface FastEthernet0/22
switchport access vlan 22
switchport mode access
no ip address
interface FastEthernet0/23
switchport access vlan 23
switchport mode access
no ip address
interface FastEthernet0/24
switchport access vlan 24
switchport mode access
no ip address
interface Vlan1
no ip address
no ip route-cache
shutdown
ip default-gateway xyz.xyz.xyz.xyz
no ip http server
line con 0
password mypass
login
line vty 0 4
password mypass
login
line vty 5 15
password mypass
login
ntp server xyz.xyz.xyz.xyz
end